xpms2d Download Page

System Requirements

To build xpms2d from source requires an X-Windows based operating system using the Motif toolkit. Most commercial Unices have Motif installed.

OpenMotif is available for RHEL via yum(1) ("yum install openmotif openmotif-devel"). For Fedora, visit RPM find and download the openmotif and openmotif-devel RPMs.


Mac DMG (Mountain Lion)

XQuartz is required.
xpms2d.dmg

Linux RPMs

RHEL 6 x86_64 2.7.0
RHEL 6 x86_64 2.6.2
RHEL 6 x86_64 2.6.1
RHEL 6 x86_64 2.6.0

For RHEL 6 and Fedora 10+ the fonts used by ncplot, ncpp, and xpms2d are not installed by default. If it core dumps on start up, messages about fonts not found, and square boxes instead text, then try this:

yum install "xorg-x11-fonts-ISO*"


Source code

Source code is now on github (git clone --recursive https://github.com/ncar/aircraf_oap). https://github.com/ncar/aircraft_oap
xpms2d-2.7.0.tar.gz
xpms2d-2.6.2.tar.gz
xpms2d-2.6.1.tar.gz
xpms2d-2.6.0.tar.gz
libraf++.tar.gz


2D / OAP File Format

OAP File Format


Change log